This blog post is written by Kiran Poluri and Krishnaprasad K from Dell Hypervisor Engineering team.

When upgrading from Dell customized VMware ESXi 5.0 to a later update using Dell customized VMware ESXi 5 ISO image, it fails with an error message as shown below.

This error occurs since the later versions of Dell customized VMware ESXi 5 ISO image carries different VIB name which provides the same set of files compared to Dell customized VMware ESXi 5.0. The upgrade is not successful when you encounter this issue. Once you reboot from this error prompt, it rolls back to ESXi 5.0. There is no data loss or configuration loss due to this error. Follow one of the below methods to resolve the issue before upgrade or after the issue is seen.

Method1
                From the ESXi 5.0 shell, run the following commands.
                           ~# esxcli software vib remove –n Dell-Configuration-VIB
                           ~# esxcli software vib remove –n Dell-License-VIB

                Once the command execution is successful, start upgrading using Dell customized VMware ESXi 5 ISO.

Method2
                Use VMware native ESXi 5 ISO image or VMware upgrade package to upgrade from Dell customized VMware ESXi 5.0.