DELL-spezifische SNMP-Werte vom Precision T3400 abfragen.

Systems Management

Systems Management
Systems Management

DELL-spezifische SNMP-Werte vom Precision T3400 abfragen.

  • Hallo,

    mich würde es sehr interessieren, ob es möglich ist, auch vom Destktop PC, in meinem Fall ein DELL PRECISION T3400, einige Werte z. B. Temperature von der CPU, Festplatte, Lüfterdrehzahl, ... per SNMP abzufragen. Beim Servern gibt es ja sowas, aber bei Workstations?

    Die Desktop-PC's werden bei uns als Leitrechner (Client) für die Produktion eingesetzt. Und die Verfügbarkeit eines solchen Rechners steigt immer höher, da auch das Personal immer weniger wird. Da ist es auch sehr wichtig, rechtzeitig einen Temperaturanstieg eines Clientrechners festzustellen.

    Die Überwachung sollte per SNMP stattfinden.

    Gruß

    harry

  • Hallo Harry,

    die SNMP Überwachung beim Client ist leider nicht so einfach wie beim Server.

    Die Precision kann Remote überwacht werden aber dafür sind einpaar Änderungen am Client notwendig und du benötigst zusätzlich ein Stück Software als Transiver.

    Du musst in BIOS des Systems ASF (Alert send function) aktivieren. Diese findest du unter Maintenace..

    ASF This field controls the ASF management mechanism. Options are ON (full ASF 2.0 functionality (RMCP)), Alert Only (send ASF messages on event or error), and OFF (all ASF functionality disabled).

    Danach benötigst du eine Software auf dem Client um die Daten auszutauschen. Diese nennt sich Dell Open Manage Client Instrumentation oder OMCI.

    en.community.dell.com/.../1773.openmanage-client-instrumentation-omci.aspx

    Wie du danach im Detail vorgehen musst kannst du hier entnehmen.

    en.community.dell.com/.../20101707.aspx

    Anbei noch die SNMP MIBs die in der Anleitung angesprochen werden.

    ftp.dell.com/.../DCMIB71.zip

    Bitte beachte auch das nicht alle Alerts in der Precision implementiert sind.

    P.s. solltest du Siemens WinCC, Siemens Step 7, Siemens Step 5 oder Siemens PC S7 etc. auf deinem Leitstand einsetzen würde ich es vorher an einem anderen System testen.

    Meiner Erfahrung nach haben sich Siemens Symatic Produkte immer etwas, wenn man zusätzlich Netzwerksoftware installiert.

  • Hallo Florian,

    erstmal danke für die schnelle Antwort.

    Ich werd's mal an unserem Testsystem ausprobieren.

    P.s. Auf unseren Systemen läuft das Leitsystem von ABB.

     

  • Hallo Harry,

    ok. Gib mir dann einfach Feedback wie es funktioniert.

    ABB ist gut und hat sich nicht so zickig wie WinCC was das angeht.

  • Hallo,

    also:

    noch kann wenig berichten, weil die Installation nicht fehlerlos ablief.

    Gegen Ende der Installation will es irgendeinen Dienst (Services) starten, danach erscheint ein Fehlerfenster vom "System Management Data Manager"

    Error Rreport:

    Und wenn ich dann diese Meldung schließe, kommt die Fertigmeldung der Installation von OMCI.

    Ich habe aber keinen neuen Dienst im Tastmanager registriert.

    Auch wenn ich die Datei (s. Fehlerbericht: dsm_sa_datamgr32.exe) starte kommt dieselbe Fehlermeldung wie oben.

    Und auch mit MIB-Browser sehe ich keine Dell-Werte.

     

    Ich weiß nicht, ob ich mich deutlich ausgedrückt habe.

    Falls nocht irgendwelche wichtige Infos fehlen, bitte fragen.

    harry

  • Hallo Harry,

    welches Betriebssystem verwendest du? Welche OMCI Version hast du dir heruntergeladen?

    Grüße

  • Hallo Steffen,

     

    ich hab Windows XP Prof. SP3 (deutsch und englisch) ausprobiert.

    OMCI 8.1.1 , habe auch die 8.1.0 probiert.

    NET Framework 3.5 SP1

     

    Gruß

    harry

     

  • Hallo Harry,

    vielen Dank für deine Antwort.

    Hast du die 32bit oder 64bit Anwendung genutzt?

    Ich habe dir hier mal den Link für die 32bit Version herausgesucht, kannst du die bitte einmal testen?

    http://www.dell.com/support/drivers/de/de/debsdt1/DriverDetails?driverId=5D2HG

    Bitte führe die Installation auch als Administrator aus ;)

    Grüße

    Steffen

  • Hallo Steffen,

    hab erst jetzt gesehen, dass ich diese Angaben vergessen hab anzugeben.

    Ich habe die 32Bit Version von Windows XP Prof. SP3

    und hab auch genau die obere Version von OMCI installiert (als Admin).

    Auch den Avira Free AntiVirus habe ich deaktiviert.

    Zur Info: Der Rechner hat keine Verbindung zum Internet.

    Benötigt OMCI vielleicht irgentwelche Dienste/Einstellungen von Windows, die evtl. bei mir nicht aktiv sind?

    Gruß

    harry

  • Hallo Steffen-D

    Ich bin bereits per E-Mail mit Ihnen in Kontakt bezüglich USV. Leider erlitt mein Computer einen Festplattenschaden und ich kann vorherige E-Mails nicht mehr abrufen und so habe ich auch Ihre E-Mail Adresse nicht mehr. Könnten Sie sich per Mail wieder bei mir melden, so dass ich Ihre E-Mail Adresse wieder habe.

    Vielen Dank im Voraus.

  • Hallo Harry,

    erst einmal Entschuldigung das ich länger nichts von mir hören lassen habe. Ich werde die Installation mal bei uns durchspielen müssen. Ich kann dir aber leider noch nicht genau sagen, wann ich das schaffe. Ich hoffe dir diese Woche noch eine Antwort geben zu können.

    @ videokonsole: EMail ist versendet ;)

    LG

    Steffen

  • Hallo Steffen,

    hab mich entschlossen, mal nachzufragen. Nicht dass ich es dringend brauche, aber vielleicht hat sich in der Zwischenzeit schon was getan. Und falls nicht, dann kann ich auch noch eine Weile warten. Schließlich gibt es wichtigere Dinge :)

    LG

    Harry