!

Bitte beachten Sie: Veeam wird von DELL offiziell nicht unterstützt.

Als mögliche Lösung bei Problemen mit der Nutzung von Veeam mit LTO Bandlaufwerken am PERC H330 und der Verwendung des von VEEAM geforderten IBM Treibers haben wir die Verwendung des Microsoft LTO Treibers getestet. Es handelt sich dabei um einen Workaround, welcher in unserem Labor mit bestimmten Hard- und Softwareständen erfolgreich getestet wurde. Aufgrund der vielen möglichen Kombinationen von Hard- und Software können wir allerdings keine Garantie übernehmen, dass die Lösung in allen Umgebungen funktioniert:

Testumgebung:

- Power Edge T430 mit PERC H330 Adapter und LTO 6 Tapelaufwerk
- Windows 2012R2 mit allen aktuellen Patches (Stand 06/2016)
- Veeam Backup&Replication 9.0.0.1491
- Getestete PERC H330 FW Stände: 25.3.0.0016; 25.4.0.0017; 25.4.1.0004
- Getesteter PERC Treiber: 6.603.07.00

Im gegeben Szenario wurden 3 LTO Bänder mit Veeam unter Nutzung folgender FW-/ Treiberstände mit verschiedenen Blockgrößen ( 64kB, 128kB, 256kB) mit Veeam beschrieben:
- PERC H330 FW: 25.3.0.0016
- PERC H330 Driver: 6.603.07.00
- IBM Tape driver: 6.2.5.6
- LTO6 FW: F9A1

Die beschriebenen Bänder wurden durch testweise Wiederherstellung von Dateien validiert.
Anschließend wurde der IBM Treiber durch den aktuellen Microsoft Treiber von Windows 2012R2 wie nachfolgend beschrieben ersetzt:

Zunächst wurde der installierte Treiber (6.2.5.6) mit der ‚uninst.exe‘ aus dem IBM-Treiberpaket deinstalliert:

Nach dem anschließenden Reboot wird das LTO Laufwerk mit einem gelben Ausrufezeichen angezeigt. 

Nun muss der Microsoft Treiber manuell installiert werden:

Nach einem weiteren Neustart sollte das Laufwerk jetzt als LTO Tapedrive angezeigt werden, der installierte Treiber ist jetzt der Microsoft Treiber.
Version: 6.3.9600.16384

Anschließend wurde ein vorher mit Veeam und dem IBM Treiber  beschriebenes Medium inventarisiert:

Dies wurde mit allen 3 vorher beschriebenen Medien (64kB, 128kB und 256kB Blocksize) durchgeführt.
Dabei wurden zunächst von jedem Medium 1 Datei Testweise wiederhergestellt und anschließend ein weiteres Backup auf das jeweilige Medium durchgeführt. Dabei traten keine Probleme/Störungen auf.
Bei weitergehenden Tests konnte folgendes Verhalten von Veeam mit dem Microsoft Treiber festgestellt werden:

  1. Bänder die vorher mit dieser Veaam Installation beschrieben wurden konnten ohne Einschränkung inventarisiert werden. Eine Wiederherstellung von Daten und eine weitere Nutzung für Backups ist ohne Einschränkung und unabhängig von der Blockgröße möglich. Ein Löschen oder Formatieren des Bandes war nicht erforderlich.
  2. Neue, unbenutzte Bänder konnten problemlos inventarisiert und uneingeschränkt für Backups und nachfolgende Wiederherstellung genutzt werden.
  3. Bänder die vorher mit anderen Backup Applikation oder Testtools wie ITDT beschrieben wurden, konnten mit Veeam weder inventarisiert, beschrieben, gelöscht oder formatiert werden. Dies war erst nach dem Löschen des Bandes mit einem geeigneten Drittanbieter-Tool (in diesem Fall ITDT) möglich. Nach dem einmaligen Löschen war eine uneingeschränkte Verwendung unter Veeam jedoch möglich.

Bei der unter Punkt 3 beschrieben Problematik zeigt sich folgendes Verhalten:
Die Inventarisierung selbst läuft scheinbar fehlerfrei, das Laufwerk wird jedoch weiterhin als leer angezeigt und demzufolge ist weder ein Backup auf dieses Medium möglich, noch ein Löschen desselben. In diesem Fall muss das Medium mit einem Drittanbieter-Tool wie ITDT gelöscht werden.
Danach ist das Medium problemlos inventarisier- und nutzbar.
Um das Band für die weitere Nutzung mit Veeam mittel des ITDT Utility zu löschen, gehen Sie wie folgt vor:
Starten Sie ITDT als Administrator:

Tippen Sie U für "[ U ] Tapeutil" und Enter.

Tippen Sie 1 für "[ 1 ] Open a Device" und Enter.

Fortsetzten mit Enter.

Fortsetzten mit Enter.

Fortsetzten mit Enter.

Das Gerät wurde erfolgreich geöffnet, fortsetzten mit Enter.

Tippen Sie 28 für "[ 28 ] Erase" und Enter.

Der Löschvorgang wird gestartet. 

Hinweis: der Löschvorgang (es handelt sich um einen "long erase") dauert mehrere Stunden. Er kann durch Reseten des Laufwerkes (drücken des Auswurfknopfes für mindestens 15 Sekunden) unterbrochen werden, das Band ist nach dem erneuten Laden durch Veeam problemlos nutzbar.

Sollten Sie beim Starten des Löschvorganges folgende Meldung erhalten:

Führen Sie bitte folgende Schritte durch und versuchen Sie danach jeweils den Löschvorgang erneut zu starten:

  1. Prüfen Sie ob das Band tatsächlich in das Laufwerk geladen ist, und laden Sie es gegebenenfalls erneut.
  2. Entladen/laden Sie das Tape.
  3. Starten Sie das System neu.

Folgendes Verhalten ist aktuell noch ungeklärt:

  1. Bänder die vorher mit Veeam unter Nutzung des IBM Treibers beschrieben wurden, werden von ITDT bei Verwendung de Microsoft Treibers als schreibgeschützt erkannt. Nach dem Löschen, wie vorstehend beschrieben sind Sie jedoch normal nutzbar.
  2. Bei installiertem IBM Tapedriver ist teileweise ein Up- / oder Downgrade der PERC FW nicht möglich (‚kein unterstütztes Device gefunden‘). Teilweise ist das Up- / Downgrade nach einem Neustart möglich, in Einzelfällen jedoch nur nachdem das LTO Laufwerk physikalisch vom Controller getrennt wurde
  3. Bei installiertem IBM Tapedriver ist teileweise ein Up- / Downgrade der LTO Firmware nicht möglich. Teilweise ist dieses nach Neustart möglich, in Einzelfällen nur nach Up- / oder Downgrade der PERC FW oder Wechsel zum Microsoft Treiber. 

Disclaimer:
Diese Artikel werden als Hilfestellungen für Sie zur Verfügung gestellt. Jeder Artikel wird von unseren Mitarbeitern gewissenhaft erarbeitet und von Technischen Spezialisten nochmals überprüft. Wir bitten um Ihr Verständnis, dass auf Grund der Fülle an Inhalten nicht jeder Artikel zeitnah inhaltlich geprüft werden kann. Über Ihr Feedback und notwendige Änderungen, zu den Artikeln, freuen wir uns sehr. Bitte senden Sie diese an: DellHilftPro