OpenManagePrinterManagerv.2.3

Dell Client

Dell Client
Dells Client Systeme

OpenManagePrinterManagerv.2.3

  • Hallo,

    ich hoffe ich bin hier richtig... Ich brauche hilfe bei der Installation von Dell OpenManagePrinterManagerv2.3 auf einem Windows Server 2008R2, ich erhalte immer den Fehler:

    "PostGreSQL database is not installed properly. PostGreSQL service is not registered on the system. Please reinstall PostGreSQL and then install OMPM."

    Das hier ist das PostGreSQL Installations Log bzw der betroffene Part davon:

    The database cluster will be initialized with locale English_United States.1252.
    The default text search configuration will be set to "english".

    fixing permissions on existing directory C:/Program Files (x86)/PostgreSQL/8.4/data ... initdb: could not change permissions of directory "C:/Program Files (x86)/PostgreSQL/8.4/data": Permission denied

    Ending DoCmd()...
    Called Die(Failed to initialise the database cluster with initdb)...
    Failed to initialise the database cluster with initdb

    Script stderr:
    Program ended with an error exit code

    Error running cscript //NoLogo "C:\Program Files (x86)\PostgreSQL\8.4/installer/server/initcluster.vbs" "postgres" "postgres" "****" "C:\Program Files (x86)\PostgreSQL\8.4" "C:\Program Files (x86)\PostgreSQL\8.4\data" 5432 "DEFAULT" : Program ended with an error exit code
    Problem running post-install step. Installation may not complete correctly
    The database cluster initialisation failed.
    Problem running post-install step. Installation may not complete correctly
    The database cluster initialisation failed.
    Creating Uninstaller
  • Hallo ben_g!

    Das Installationsprogramm konnte die Verzeichnisberechtigungen nicht setzen.

    Öffnen Sie das PostgreSQL-Verzeichnis "c:\Program Files(x86)\PostgreSQL\8,4\" um manuell die Berechtigungen für das "data"-Unterverzeichnis zu vergeben. Sollte dieses Verzeichnis noch nicht vorhanden sein,  erstellen Sie es einfach und setzen Sie die Berechtigungen für Benutzer-Gruppe auf  "Vollzugriff". Danach müssen Sie PostgreSQL deinstallieren und erneut installieren. Diesmal sollte bei der Installation keine Fehlermeldung auftretten und der Server sollte laufen.

    Als Alternative kann man das Installationsverzeichnis auch ändern und z.b "c:\Programme\PostgreSQL\8,4\" nutzen.

  • Hallo Steffen,

    danke für den TIpp, aber das hat auch nicht funktioniert, gleicher Fehler.

    Wie kann ich das Installationsverzeichnis ändern?

    Wie gesagt, ich arbeite mit der Dell Installationsdatei: OpenManagePrinterManagerv2.3.exe

    Es scheint mir als wäre hier alles hinterlegt :-/

    Gruß

    Ben

  • Hallo Ben,

    dann könnten wir folgendes versuchen:

    1. OpenManagePrinterManagerv2.3; PostgreSQL Installation und Directory löschen: "C:\Program Files\PostgreSQL\8.4\data"  (bitte richtige Versionsnummer nutzen)

    2. akuelle PostgreSQL Core Distribution herunterladen:

    www.postgresql.org/download

    3. akuelle PostgreSQL Core Distribution mit Lokalen Admin Rechten installieren unter z.B. "C:\PgSQL\" installieren.

    Ich vermute der "'postgres'" Nutzer wurde lokal angelegt.

    4. Wenn das alles erfolgrei war, dann OpenManagePrinterManagerv2.3.exe installieren.

    Hoffe das hilft dir weiter ;)

    Gruß

  • Hallo Steffen,

    das wars!

    Damit hat es geklappt!

    Vielen Dank!

    Noch eine Frage, mit was logge ich mich ein? Im PDF Steht "admin" und "welcome" das funktioniert aber leider nicht :(

  • Rafael hat die Logindaten scheinbar!

    de.community.dell.com/.../142.aspx

  • Hallo Ben,

    Leider ist Rafael im Moment nicht verfügbar.

    Ich werde die Installation mal selber durchführen, um dein Problem nachzustellen, denn ich habe die selben LoginDaten wie du vorliegen.

    Werde mich morgen früh wieder hier an dieser Stelle melden, um dir die korrekten LoginDaten mitzuteilen.

    Bis dahin noch einen schönen Abend!

  • Guten Morgen Ben,

    Also Testserver ist installiert, Login funktioniert mit admin/welcome.

    Nach dem erstmaligen Anmelden erscheint sofort wieder ein Screen der ähnlich dem LoginScreen ist, wo man aufgefordert wird, das Passwort zu ändern.

    Bitte achte auf die Kleinschreibung der LoginDaten!

    Gruß

  • Guten morgen Steffen,

    mensch das ist ein Service hier :)

    Also, habe es grade nochmal probiert, ohne Erfolg.

    Gibt es eine möglichkeit die Login Daten iregdnwie zu ändern? - Oder muss ich alles deinstallieren und neu installieren?

    Wie hieß dein Installationsfile & wo hast du es runtergeladen?

    Grüße

    Ben

  • achja.. den Tipp vom Manual S. 168 mit AdminPasswordReset.jar hab ich schon versucht...

    Passwort Reset failed!

  • Also, ich habe jetzt alles deinstalliert, alles gelöscht was ich an files + foldern gefunden habe

    und neuinstalliert

    admin / welcome geht definitiv nicht....

  • Hallo Ben,

    die Installationsroutine habe ich unter folgendem Link heruntergeladen:

    content.dell.com/.../client-systems-management-ompm

    Anbei mal ein 2 Screenshots direkt nach der Installation:

    Eingeloggt habe ich mich mit admin/welcome.

    Danach habe ich das Passwort gewechselt:

    Das ging soweit gut.

    Der Passwortreset geht nur wenn du schon ein neues Passwort vergeben hast! Deshalb auch der Fehler, den du bekommst.

  • Hallo,

    so, nach endlosen Versuchen, hier die Lösung & der weg dort hin.

    Den Fehler sieht man ja im ersten Post.
    Daraufhin habe ich versucht eine andere Version von PostgreSQL zu installieren -> selber fehler
    Als ich dann PostgreSQL in ein anderes Verzeichnis installiert hab ging das ohne Fehler.
    OMPM hat jedoch beim Setup einen DB Connection Fehler festgestellt, trotzdem weitergemacht -> ich konnte mich später nicht einloggen
    
    
    Habe dann nochmal alles deinstalliert und wieder vorn vorne Angefangen.
    Vorher, habe ich allerdings auf C:\Program Files (x86) die NTFS Rechte folgendermaßen angepasst:
    lokale USERS Gruppe VOLLZUGRIFF
    lokaler postgres User VOLLZUGRIFF

    Anschliessend die Installation gestartet und siehe da...
    PostgresSQL Installation klappt fehlerfrei
    Rechte setzen & Registrierung der DB klappt fehlerfrei

    Dell OMPM Installation klappt fehlerfrei

    Noch ein reboot und tadaaa der Login klappt auch!

    
    
    Verrückte Welt... ich hoffe mal das das in der nächsten version gefixet ist wenn es ein Bug ist :)
    
    
    
    
    Grüße
    Ben