T20 - Wake on Lan funktioniert nicht

PowerEdge Server - Allgemeine Hardware

PowerEdge Server - Allgemeine Hardware
Diskutieren Sie mit uns über PowerEdge Server und System Management Praktiken

T20 - Wake on Lan funktioniert nicht

This question has been answered by LittleSledge

Hallo Community,

ich habe mir für den Heimbedarf einen kleinen T20 zugelegt und mit WSE12 bespielt. Funktioniert alles soweit.

Jetzt zum Problem:

Ich möchte mit Lights-Out gerne den Server "wecken" wenn daheim einer nen PC macht. Das funktioniert aber nicht weil WOL nicht macht wies soll.

Wenn ich den den Rechner in den Standby oder Ruhezustand versetzte und während dessen von einem Client ein Magic-Package spame (halt sehr oft hintereinander) dann funktioniert und er wacht wieder auf. Wenn ich allerdings ein paar Sekunden (5 reichen schon) ein MP schicke passiert nichts.

Kann mir da jemand weiter helfen?

BIOS-Update ist bereits installiert.

Vielen Dank vorab!

Gruß

Alex

Verified Answer
  • So nach langem hin und her mit den A04 BIOS funktioniert das Ganze.

    Was habe ich gemacht:

    BIOS geflasht Load defaults -> keine änderung

    BIOS Reset Setting Jumper durchgeführt

    Danach die DeepSleep disabled

    Die NIC nur enabled

    WOL nur bei LAN aktiviert

    nun ist die LED der NIC sofort an nachdem ein Shutdown durchgeführt wurde.

    Wichtig ist auch, dass Windows 8 so wie ich es gelesen haben kein S5 / S4 supportet.

    Aus diesem Grund habe ich LightsOut mit herunterfahren eingestellt.

    Hierbei kann aber noch der Schnellstart seine Schuldigkeit beigetragen haben.

    Dieser wird wohl auf neuer Hardware aktiviert. Dies sollte deaktiviert werden.

    So ich bedanke mich mal an der Stelle bei allen Beteiligten.

    Grüße

All Replies
  • Hi Alex,

    vielen Dank für deine Frage.

    Deaktivier mal im BIOS unter Performance die Option C States Control und probier es noch einmal.

    Eventuell ist auch noch der Deep Sleep aktiviert, wenn ja, schalte es aus unter Power Management -> Deep Sleep Control.

    Sag bitte Bescheid, ob es geklappt hat.

    Gruß
    Stefan

  • Hallo Stefan,

    danke für deine Antwort.

    C States und Deepsleep habe ich deaktiviert. Das brachte leider keinen Erfolg. Mir ist noch aufgefallen was USB-Wake auch nicht funktioniert (Sollte doch bei Testendruck (keyboard) den Rechner wecken oder?). Das ist mir zwar nicht wichtig, aber vielleicht hilft es bei der Problemlösung.

  • Hi Alex,

    komme gerade ausm Lab - ich konnte das Verhalten bei unserem T20 nachvollziehen. Lässt sich "leider" hervorragend reproduzieren.

    Ich kann dir noch nicht genau sagen, was der Grund dafür ist. Ich kann dir anbieten, dass ich das ganze eskaliere. 
    Dafür müsstes du mir per Private Message bitte folgende Daten schicken: Service-Tag vom T20, E-Mail Adresse, zwei Telefonnummern, wo wir dich erreichen können. Gern kannst du mir auch direkt schon die Adresse mitteilen, an der das System betrieben wird.

    Gruß
    Stefan

  • Hallo Stefan,

    bei meinem T20 das selbe Problem. Bitte eskalieren.

    Soll ich meine Daten auch zu kommen lassen?


    Wake on Lan ist unverzichtbar!

    Grüße,

    Timo

  • Gleiches Problem bei mir. OS ist Windows Server 2012 R2 Standard (MAPS).
  • Hallo! Habe leider ein vergleichbares Problem: T20 lässt sich durch Wake-On-Lan nicht aktivieren. (Auch nicht durch mehrere Pakete). Wake-on-USB geht, aber nur wenn ich mehrfach eine Taste drücke. Bin mir aber sicher, dass der Fehler erst NACH Installation von Bios A03 aufgetreten ist. Als der Rechner vor ein paar Tage mit A02 ankam, da hat es funktioniert! Hoffe Ihr findet bald ne Lösung. Gruß Peter
  • Problemlösung: Habe bei mir Wake-On-Lan zum Laufen gebracht:

    Der Hauptpunkt war ein Downgrade des Bios von A03 auf A02.

    Dies gibt es z.B. auf der estnischen Dell Support Seite (googlen nach:  dell t20 a03 a02)

    Vor dem Downgrade waren sowohl an der Netzwerkkarte als auch am Router kein Signal im Standby (Lichter aus), nach dem Downgrade war das Licht an und Wake on Lan ging.

    (Passager hatte ich auch mal die Windows8-Firewall abgeschaltet, da gab es zwischenzeitlich ein Problem, wohl weil beim Downgrade ein Neues Windows-Netzwerk erstellt wurde).

    Viel Erfolg.

    Peter

  • Hallo Peter,

    habe gerade deinen ersten Post gelesen und habe mich gefragt ob ein Downgrade ohne Probleme möglich ist, aber da du es jetzt ja schon getestet hast werd ich mich mich auch gleich mal dran begeben.

    Trotzdem wäre mir ein Update seitens DELL immer noch recht ;-)

    Vielen Dank für deine Anteilnahme Big Smile

    Gruß

    Alex

  • Hallo an alle,

    super, dass es nach dem Downgrade bei dir klappt Peter. Ich konnte dies an unserem T20 hier leider nicht nachvollziehen. Das Verhalten ist sowohl mit A02 als auch mit A03 gleich.

    ABER

    Ich habe herausgefunden, dass die Intel NIC nach dem Herunterfahren etwa eine Minute benötigt, um wieder aufnahmebereit zu sein. Ab dann ging der T20 immer sofort per Magic-Package an.
    Die Activity-LED plinkt direkt nach dem Ausschalten rythmisch im 1-2 Sekunden-Takt. Nach etwa einer Minute wechselt das Blinkverhalten. Die LED blinkt dann öfter - und ab da nimmt er das Magic-Paket sofort an. Ohne zu spammen.

    Es liegt also an der NIC und an der Zeit die diese benötigt um auf Pakete zu reagieren.

    Versucht das bitte einmal, also nicht sofort nach dem Ausschalten direkt Pakete schicken, sondern etwa eine Minute warten.
    Wenn Ihr das System griffbereit habt, schaut mal auf die LEDs.

    Gruß
    Stefan

  • Hallo,

    Ich habe auch das Bios A03 installiert. Mein T20 hat Wake on Lan garantiert angeschaltet im Bios, aber da blinkt nichts. Hab 2 min gewartet, dass da etwas blinkt.

    Gerät hängt natürlich an Strom und Lan.


    Gruß

    Timo

  • Hallo,

    also mein T20 hat nun fast das von Stefan besagte Verhalten, nur das er sofort wieder aufwacht (keine Wartezeit). Allerdings mit BIOS A02. Mit A03 hat die NIC weder geleuchtet noch geblinkt. BIOS-Einstellungen habe ich auf Default, bis auf AHCI und Wake-On-Lan natürlich.

    Daher vertrete ich die Meinung das es am BIOS liegt und nicht an der NIC <- btw. mit aktuellstem Treiber von der Intel-Page.

    Gruß

    Alex

  • @Tijay: Kannst du bitte einmal die BIOS defaults laden, danach das BIOS erneut aufrufen und folgende Punkte überprüfen:

    • System Configuration | Integrated NIC : Enabled
    • Power Management | Deep Sleep Control : Disabled
    • Power Management | Wake on LAN : LAN Only

    Alles speichern und neu starten - wenn die LEDs am LAN-Port noch immer nicht aktiv sind, bitte ich dich darum direkt unsere Server-Hotline zu kontaktieren, eventuell liegt ein Fehler in der NIC vor.

    @AlexSt1988: Ich habe das Verhalten sowohl mit A02 als auch mit A03. Wir haben jeweils nur eine BIOS Version - also kann ich sagen, dass wir beide die gleichen nutzen. Einzig der Treiber für die NIC, da habe ich unseren Dell-Treiber genommen, mit dem Intel Treiber habe ich es nicht probiert, das könnte eventuell noch den Unterschied bedeuten. Das werde ich noch nachvollziehen.

    Fazit: Sowohl mit A02 als auch mit A03 (und dem Dell NIC Treiber) funktioniert WOL nach einer kurzen Wartezeit, nach dem Ausschalten problemlos. 

    Gruß
    Stefan

  • Hallo Stefan,

    ich habe es genau so gemacht, wie du beschrieben hast, leider hat dies nicht den erhoften Erfolg gebracht.

    Ein Downgrade auf A02 hat geholfen. Wake on Lan geht jetzt bei mir, hab ihn gerade geweckt. .

    Hier der Link auf A02: http://www.dell.com/support/drivers/de/de/19/driverdetails?driverid=0R2M8

    Ich habe übrigens den Treiber von der DELL HP. Denke aber auch nicht, dass ein Windows Treiber einfluss auf die Wake on Lan funktionen hat.

    Wäre schön, wenn ihr da trotzdem in die Firmware mal reinschaut, was da los ist.

    Grüße

    TiJay

  • Hi,

    ich habe heute noch einmal folgendes bei unserem T20 nachgestellt:

    1. BIOS A02 und Windows Default Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist
    2. BIOS A02 und Dell Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist
    3. BIOS A02 und Intel Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist
    4. BIOS A03 und Windows Default Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist
    5. BIOS A03 und Dell Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist
    6. BIOS A03 und Intel Treiber: WOL geht, nachdem NIC etwa 30 Sekunden am Netz ist

    WOL funktioniert super, wenn man der NIC nach dem Abschalten etwa 30 Sekunden Zeit lässt sich zu aktivieren.

    Ich ging auch nicht davon aus, dass der Treiber einen großen Unterschied bringt, aber man weiß ja nie was der Treiber in den EPROM der NIC schreibt. Ich habe es auf jeden Fall versucht und kann sagen, dass WOL insoweit problemlos funktioniert.

    Sollte vereinzelt doch noch ein Problem auftreten, dann empfehle ich euch direkt den Server-Support zu kontaktieren, dann kann individuell noch einmal geschaut werden, was nicht funktioniert.

    Gruß
    Stefan

  • Hallo und guten Tag!

    Ich habe seit kurzem auch so ein Gerät. Beim Flashen der Version A03 ist mir aufgefallen das kurz und bündig eine Fehlermeldung am unteren Rand des Bildschirms erscheint: ME FW Update Failed,Please Try again! Der Flashvorgang an sich wird mit grüner Schrift und "Successful" beendet. Beim A03 Bios ist es mir nie gelungen den WOL zu initiieren. Rückflashen hat auch bei mir geholfen, nachdem ich stundenlang rumgedoktert habe. Zum ersten mal gelang mir WOL mit einer andere PCI-Netzwerkkarte von Intel die ich noch so rumliegen hatte. Nach vielem Gefrickel und ständigem Treiberwechsel macht es nun auch der Onboard-NIC. Sogar Zusammenfassen beider Karten zu einem Team funktioniert sehr gut unter WSE 2012. Für mich deutet alles darauf hin, das im A03 Bios ein "dicker Bolzen" drin ist. Schönes WE!