Perfekte iSCSI-Config für 6224 ?!?!

Netzwerk Switch

Netzwerk Switch
A description has not yet been added to this group.

Perfekte iSCSI-Config für 6224 ?!?!

This question is not answered

Hallo :)

ich richte gerade 2 Dell PowerConnect 6224 für iSCSI ein. Ich bin mir nicht sicher, ob die Config so komplett ok ist, da unsere HP ProCurve 2848 irgendwie mehr IOPS schaffen und das ohne JumboFrames.

Die Switches sind beide identisch eingerichtet. Die Stacking-Module sind noch nicht geliefert worden, daher teste ich aktuell mit einem LAG. Die Performance ist jedoch egal ob ich einen oder beide Switches verwende gleich! Port 1 wird zur Verwaltung der Switches verwendet.

Vielleicht hat ja noch jemand einen Tipp zur Optimierung?

Config:

console#show running-config
!Current Configuration:
!System Description "PowerConnect 6224, 3.3.5.5, VxWorks 6.5"
!System Software Version 3.3.5.5
!Cut-through mode is configured as disabled
!
configure
vlan database
vlan 10
exit
stack
member 1 1
exit
ip address X.X.X.X

ip address vlan 10
!
interface ethernet 1/g1
storm-control broadcast
storm-control multicast
spanning-tree portfast
switchport access vlan 10


exit
!
interface ethernet 1/g2
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g3
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g4
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g5
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g6
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g7
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g8
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g9
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g10
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g11
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g12
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g13
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g14
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g15
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g16
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g17
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g18
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g19
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216


exit
!
interface ethernet 1/g20
storm-control broadcast
storm-control multicast
spanning-tree portfast
mtu 9216
exit
!
interface ethernet 1/g21
channel-group 1 mode on
mtu 9216
exit
!
interface ethernet 1/g22
channel-group 1 mode on
mtu 9216
exit
!
interface ethernet 1/g23
channel-group 1 mode on


mtu 9216
exit
!
interface ethernet 1/g24
channel-group 1 mode on
mtu 9216
exit
!
interface port-channel 1
mtu 9216
exit
exit

 

 

All Replies
  • Hallo Alex, 

    ich lasse gerade meine Netzwerkkollegen mal drüber schauen. Sobald ich Feedback habe, melde ich mich zurück. 

  • Hallo Alex, 

    die Kollegen haben gerade noch nach folgenden Infos gefragt. 

    Welches Storage hast du angeschlossen?

    Welches Host-OS setzt du ein? 

    Firmware Version vom Switch? 

    Für die EQLs von Dell gibts hier schonmal eine Anleitung: 

    http://en.community.dell.com/techcenter/storage/w/wiki/3615.rapid-equallogic-configuration-portal-by-sis.aspx

  • Hallo Florian,

    die Performance-Probleme scheinen daher zukommen, dass Ports auf Switch 1 Ports auf Switch 2 nicht erreichen können und andersrum. Es muss mit der LAG Konfiguration zutun haben. Sobald sich 2 Hosts auf dem gleichen Switch befinden funktioniert alles. Das Storage verwendet aber aktuell RoundRobin Multipathing. Somit ist die hälfte der Links zum Array down.

    Wir setzen aktuell noch eine MSA P2000 G3 von HP ein. Nächste Woche soll eine EQL PS4100XS dazukommen.

    Host OS ist ESXi 5.1

    Switch FW 3.3.5.5

    Ich habe bereits einige Anleitungen im Netz gefunden, jedoch finde ich den Fehler in meiner Config nicht...

  • Die Kollegen haben grad drüber geschaut und VLAN 10 ist nicht im LAG. Dieses liegt aber auf besagtem Switchport 1. 

    Da wir aber die Funktion nicht genau kennen, würden wir erstmal schließen, dass eventuell hier der "Hund begraben liegt". 

  • Ich habe VLAN 10 nur angelegt um den iSCSI-Traffic vom Mgmt-Port (g1) zu trennen. VLAN10 ist also nur für Port 1 und somit zum managen des switches. Alle anderen Ports sind im default vlan. 

  • Hi Alex, 

    ok. Wäre es ok für dich kurz bei meinen Kollegen vom Support anzurufen? Da man wahrscheinlich noch tiefer in dei ganze Sachen schauen müsste, wäre es nicht sehr zuträglich eine Postschlacht zu starten. 

    Es wäre gut wenn du mir deine Mailadresse via PM schickst und ich dich in Kontakt mit den Kollegen bringen kann oder du rufst direkt mal bei Ihnen an. 

    Herr Gonschorek ist bereits informiert und eventuell kann er den Fall auch direkt übernehmen. 

    Enterprise Support Services Montag - Freitag: 08:00 - 18:00 Telefon:
    069 9792 4299