XPS 13 9360 / MLK kein Audio-Gerät im BIOS nach Standby (in Ubuntu)

Laptops - Allgemeine Hardware

Laptops - Allgemeine Hardware
Diskutieren Sie mit uns über Dell Laptops

XPS 13 9360 / MLK kein Audio-Gerät im BIOS nach Standby (in Ubuntu)

This question has been answered by JSMLK

Hallo,

Symptome:

  • nach Aufwachen aus dem Standby in Ubuntu bekomme ich eine Auswahl, welches neue Audio-Gerät ich eingesteckt hätte (obwohl ich keines eingesteckt habe)
  • Audio geht bereits zu diesem Zeitpunkt nicht mehr, egal welches Gerät man dann noch auswählt
  • Audio geht auch über Neustarts hinweg nicht und unter Soundgeräten steht dann nur noch "Dummy Output"
  • Ausschalten (und wieder Einschalten) zeigt ebenfalls keine Wirkung
  • Live-Version von Linux hat ebenfalls nur "Dummy Output"
  • im BIOS in "System Information" steht "Audio Controller =(none)"

Problem lässt sich durch deaktivieren und reaktivieren der Audio im BIOS wiederherstellen, aber der Fehler tritt nach jedem Standby wieder auf.

Eckdaten:

  • XPS 13 MLK (Baugleich zu 9360 afaik)
  • BIOS 1.0.7
  • Kernel 4.4.0-47
  • komplett aktualisiert (via apt update & dist-upgrade)
  • außer mpv, git und chromium nichts weiter installiert

Ein ähnliches Problem wurde hier en.community.dell.com/.../19682246  beschrieben. Hier handelt es sich allerdings um den Vorgänger dieses Laptops und eine andere Kernel-Version (3.19.x). Hier lässt sich das Problem auch nicht durch herunterfahren lösen. Das Problem tritt ebenfalls auf, wenn ich oben rechts "Suspend" auswähle (im Gegensatz zum Problem im Thread).

Mit freundlichen Grüßen

JS

Verified Answer
  • Offensichtlich kümmert das niemanden sonst, obwohl das ja scheinbar auch ein BIOS-Bug ist, aber falls jemand über das gleiche Problem stolpert, hier die (vorläufige) Lösung des Problems:

    1. Man suche sich den passenden Kernel im http://kernel.ubuntu.com/~kernel-ppa/mainline/ heraus
    2. Unter "build for amd64" linux-headers-..._all.deb, linux-headers-..._amd64.deb und linux-image-...._amd64.deb herunterladen. Die drei Punkte stehen hier für alles was dazwischen steht (Versionsnummer, Datum etc)
    3. Terminal öffnen (Strg+Alt+T) zum Download-Ordner navigieren (meist ~/Downloads)
    4. "sudo dpkg -i linux-*-[VERSION]*.deb" [VERSION] durch die Version ersetzen zB 4.9.0-040900rc7

    Bei mir hat es mit 4.9.0 rc7 funktioniert. Es scheint weitestgehend alles zu funktionieren, insbesondere fehlen keine Audiogeräte nach dem Standby, aber auch HDMI-Soundausgabe und Kopfhörererkennung etc funktionieren, was bei 4.8.11 nicht der Fall war.

All Replies
  • Offensichtlich kümmert das niemanden sonst, obwohl das ja scheinbar auch ein BIOS-Bug ist, aber falls jemand über das gleiche Problem stolpert, hier die (vorläufige) Lösung des Problems:

    1. Man suche sich den passenden Kernel im http://kernel.ubuntu.com/~kernel-ppa/mainline/ heraus
    2. Unter "build for amd64" linux-headers-..._all.deb, linux-headers-..._amd64.deb und linux-image-...._amd64.deb herunterladen. Die drei Punkte stehen hier für alles was dazwischen steht (Versionsnummer, Datum etc)
    3. Terminal öffnen (Strg+Alt+T) zum Download-Ordner navigieren (meist ~/Downloads)
    4. "sudo dpkg -i linux-*-[VERSION]*.deb" [VERSION] durch die Version ersetzen zB 4.9.0-040900rc7

    Bei mir hat es mit 4.9.0 rc7 funktioniert. Es scheint weitestgehend alles zu funktionieren, insbesondere fehlen keine Audiogeräte nach dem Standby, aber auch HDMI-Soundausgabe und Kopfhörererkennung etc funktionieren, was bei 4.8.11 nicht der Fall war.